Release 2018_026 (2018-08-27)

Impact

  • [NixOS] Apache servers will be restarted
  • [NixOS] ClamAV servers will be restarted
  • [NixOS] MongoDB servers will be restarted
  • [NixOS] MySQL servers and all services containing a MySQL client will be restarted
  • [NixOS] OpenVPN servers will be restarted
  • [NixOS] PostgreSQL servers and all services containing a PostgreSQL client will be restarted.
  • [NixOS] Some of the PostgreSQL-indexes need to be recreated due to the update of rum and PostGis

NixOS platform

  • Add PHP 7.2 role (7.2.7) (#105028).
  • Add PostgreSQL 10 role (10.5) (#105078).
  • Extend Apache role to load mod_deflate, mod_filter and mod_proxy_fcgi by default (#105086, #105023).
  • Fix a bug while including custom vhost-config at Apache role (#105003).
  • Security update for ClamAV 0.99.3 -> 0.99.4 (#100814).
  • Security update for PHP 5.6.34 -> 5.6.36 (#105028).
  • Security update for PHP 7.0.28 -> 7.0.30 (#105028).
  • Security update for PHP 7.1.15 -> 7.1.19 (#105028).
  • Security update for OpenVPN 2.4.3 -> 2.4.4 (#102038).
  • Security update for PostgreSQL 9.3.23 -> 9.3.24 (#105031).
  • Security update for PostgreSQL 9.4.18 -> 9.4.19 (#105031).
  • Security update for PostgreSQL 9.5.13 -> 9.5.14 (#105031).
  • Security update for PostgreSQL 9.6.9 -> 9.6.10 (#105031).
  • Update PostgreSQL/rum to 1.2.1 (#105078).
  • Update PostgreSQL/PostGis to 2.4.0 (#105078).
  • Security update for sharutils 4.11.2 -> 4.15.2 (#101089).
  • Improve robustness of fc-manage during Hydra failures (#105048).