Release 2018_022 (2018-07-19)

Impact

  • [NixOS] PostgreSQL servers and all services containing a PostgreSQL client will be restarted.

NixOS platform

  • Update PostgreSQL 9.6.8 -> 9.6.9 (#104680).
  • Update PostgreSQL 9.5.12 -> 9.5.13 (#104680).
  • Update PostgreSQL 9.4.17 -> 9.4.18 (#104680).
  • Update PostgreSQL 9.3.22 -> 9.3.23 (#104680).
  • Update PostgreSQL 9.2.15 -> 9.2.24 (#104680).
  • Update PostgreSQL 9.1.20 -> 9.1.24 (#104680).
  • Backport pipenv 10.1.0 from NixOS 18.03 (#101794).
  • Security update for vim: 8.0.1451 (#101782).
  • Improve varnish restart in systemd unit (#103578).
  • Add fix-so-path utility to fix RPATHs in shared objects shipped in binary package formats like Python wheels (#103604).

Gentoo platform

  • Fix startup bug on servers with many disk devices (#27654).